A slow Sunday, more cleaning on the motor.

So I woke up this morning, earlier than yesterday, but still not as early as one would have liked. First things first I ran to Radio Shack to get an AC power source for my Chase Cam so that I could use it to record video today.

I then started working around the garage, I didn’t shoot too much video today because I wasn’t doing too much interesting when I wasn’t working on the motor. I took the oil pan off to make sure I drained any water from the block due to my impromptu cleaning yesterday. I also put two items on the motor, the thermo stat and one of the inlet/outlets for the coolant. I would have done more but I ran into a problem today.

I can’t seem to locate the baggy of all the manifold parts from when I removed the intake/exhaust from the other motor. I found pretty much every other part I could need for the motor except for this bag. I spent much of the day tearing through things trying to locate the bag, I’ll have to keep looking this week to find the missing parts so I can get to the assembly next weekend.

Now for the video.

Recent Comments

There are currently no comments. Be the first to make a comment.

Add Comment

Please add your comment by filling out the field(s) below. Your comment may need to be approved before it becomes visible.
Enter your first name for display with the comment
Enter your last name for display with the comment.
Enter your email address so that we may contact you if necessary. We will also use this for your Gravatar.
Enter the URL to your website. URLs may be removed from comments.
Enter your comment here.
If you can't type Human in, you can't post, plain and simple.
Submit Comment Cancel